×

Welcome to TagMyCode

Please login or create account to add a snippet.
0
0
 
0
Language: Javascript
Posted by: Ryan Martin
Added: Mar 3, 2016 2:50 AM
Views: 2
Tags: no tags
The weird [if lt IE 9] syntax is not part of Rails; it’s actually a conditional comment supported by Internet Explorer browsers for just this sort of situation. It’s a good thing, too, because it means we can include the HTML5 shim only for IE browsers less than version 9, leaving other browsers such as Firefox, Chrome, and Safari unaffected.
  1. <!--[if lt IE 9]>
  2.       <script src="//cdnjs.cloudflare.com/ajax/libs/html5shiv/r29/html5.min.js">
  3.       </script>
  4.     <![endif]-->